User profile pictures are not getting updated in site collections


While administering our MOSS 2oo7 farm with many site collections which use separate content databases for each site collection, we noticed that the profile pictures are not getting updated inside the site collections (in discussion threads and other places where it shows user thumbnail, it shows users’ old picture) when the user changes it through his My Site.

The problem was because, we made the content databases offline after creating the site collection just to prevent another site collection being created in the same content database. So, in order to the profile sync between My Site and other site collections to happen, we need to leave the content databases in “ready” state. Still, if we want to prevent other site collections being created in the same content databases, we can make the maximum number of sites equal to the current number of site collection in the content database.

Reference: http://share-point.blogspot.com/2008/11/moss2007-profile-synchronization-does.html

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s